Problems with rails 3.07 and rake 0.9.0

I’m starting to program with rails, and I decided to work with the latest version of rails.

I found the first hurdle: rake rails 0.9.0 to 3.0.7

Apparently Rails 3.0.8.rc1 solve this problem with rake.

Finding the solution to these problems, without switching to a release candidate of Rails is Until rails is Rake updated to work with 0.9.x, put the Following in your project Rakefile after “require rake” and Before the call to Application.load_tasks:

class Rails::Application
include Rake::DSL if defined?(Rake::DSL)
end

Also if you prefer you can use rake 0.8.7. In this case I suggest the following (downgrade rake):

  1. run: gem uninstall rake -v 0.9 (add sudo unless you use rvm)
  2. add to your Gemfile: gem 'rake', '~> 0.8.7'
  3. and then run: bundle update

You may also like...